Gigabyte X79-UP4 Linux Horror

So I am not much of a Windows user, I have one Windows machine that doesn’t get used all the much. I tend to use Linux and have done for about 15 years. One of my work machines has caused a bit of trouble. The system was built around the Gigabyte X79-UP4 motherboard. This is on the face of it a good main-board, nice spec, good components. However I have had a lot of trouble with it. Its all about the USB 3 chipset, Linux hates it. The symptoms are as follows:

  • Anything plugged into the USB 3.0 ports and the machine will not shutdown, it instantly reboots.
  • USB 3.0 devices are unstable, and don’t always function.
  • With anything in the USB 3.0 ports the system can become unstable/unresponsive.

The solution was to deactivate all the USB 3.0 chipsets on the main-board. The the system behaves itself. I didn’t however discover this very quickly. I first tried replacing the PSU as I thought it had become damaged somehow. I then complained to Gigabyte who asked me to send the board back to them. Which I did at cost to me. They checked the board and said it was fine. They however refused to check the board with any Linux install. It is hard to replace a X79 main-board now. I so I have to continue to use it. I have however installed a PCIe USB 3.0 card that is now running the front ports on my system, and 2 on the back. I tried this board with a couple of difference Linux versions, including Ubuntu 14 and Opensuse 13.3/Leap 42.1. So, this means that I will probably never risk a Gigabyte project again, to risky.

About phil

Complex Systems Scientist.
This entry was posted in Linux Tips, Technology and tagged , , , , . Bookmark the permalink.